Array Analyzer

Main Menu: View > Array Analyzer
Shortcut:
F7
Toolbar button:

Use this window to analyze dot blots and other basic arrays or whatever kind of images arranged in grids you have.

The Array Analyzer windows has a menu bar and, on the left, four tabs: Array Settings, Calculation Settings, View Settings and Object Attributes.

Image Loading

The first step is to load an image or selection into the Analyzer window. Several buttons and Menus are going to stay disabled until an image is loaded.

File Menu
Description
Load from selection Loads the image from the active selection, or if there is no selection, from the active image window. NOTE: Important notice about loading from selections.
Load from current image Loads the image from the active image window.
Load from file Opens an Open file dialog to select the image to be loaded.

After loading an image you should define the location of the array of dot blots (or whatever array of objects you have) in the image, either automatically or by resizing and positioning a grid enclosing the objects. By default the software will draw a grid centered in the image. You should use the grid handles to position it correctly over the image and set the number of columns and rows and the diameter of the objects, in the Array Settings tab.

To locate the objects automatically click (under the Array Settings tab) to open the Find Objects window.

Slide the controls on the Find Objects window until the objects on the image are located as precisely as possible. If you want to save the settings to use them with another images you can use the Save As and Load buttons to do that.

Note: Find Objects works best with objects regularly arranged in grids, objects haphazardly arranged may not be found correctly.

After closing the Find Objects window you can adjust the position of the objects, if needed. Continue reading to learn how to do that.

Adjusting the grid and objects

Depending on the tool selected in the Tool bar (on the left, below the menu bar), you can manipulate in different ways the arrays of objects. The tool bar has three toggle buttons, each one of them selects a different tool, and also has a Calculate button:

The button on the left (shown selected in the above image) corresponds to the array sizing tool. When this tool is select (it is down), you can resize and move the array grid to adjust where the objects are drawn. This is the tool that is selected by default after you load an image.

The button in the middle is the Show/Hide button. By clicking on any objects in the array it will be shown or hidden them (hidden objects will be excluded from calculations).

The Selection button is the rightmost one. By clicking any object it becomes selected, and if it was hidden it will be shown again. Selecting on object is useful to get the data from it or to get its histogram.

The Calculate button will perform calculations on the array ob objects, based on the settings specified in the Calculation Settings tab and will show the result in a separate window, from where the data can be saved or printed. Learn More.

By default, the Draw Grid button is selected when Analyzer window appears for the first time and a default size grid is drawn on the image automatically.

That means that if you click and drag over the image a grid selection box will be drawn. The following steps show how to draw and setup a grid selection box:

  1. Set the number of columns and rows for the objet grid using the Columns and Rows text fields in the Array tab.
  2. Set the object diameter.
  3. Optionally, select the Shape for the objects. Blots are usually circular, but other shapes can be selected as well if the array comprises another kind of objects.
  4. Click on any of the handles of the array selection box over the image to position the selection box accurately.

After setting the placement of the array of objects, click on Calculate button to calculate the statistical data and show the result in a separate window.

You can select what kind of statistical values are going to appear into the spreadsheet in the Calculation Settings tab.

Only the statistical measurements selected in this tab will appear in the spreadsheet. The Decimal Positions text box sets how many decimals will be shown. After selecting or deselecting items click Calculate to open a new window with the calculation results..

Dot%

Each object will be assigned a percentage value, relative to the Mean value of the darker object, which will have a 100% value. If some objects are lighter than the background they may return negative Dot% values, but only when Subtract Background is unchecked. The same object will return zero Dot% values if Subtract Background is checked, since any pixel inside an object that is lighter than the background color will not be taken into account, only pixels darker than the background color will be processed.

Background color

The Background color will affect how the Dot% is calculated and if Subtract Background is checked, the background pixel value will be subtracted from all pixels in the objects. If Subtract Background and Dot% are unchecked the background color will not affect the calculation at all.

If all pixels in an object are lighter than the background, the object will return no data (all values set to 0), when Subtract Background is checked or return a Dot% value less than 0 when Subtract Background is unchecked.

Background Subtraction will not work correctly unless the image Background color is properly set. To do so click the Set Color button in the Calculation Settings tab, and draw a rectangle enclosing a representative area of the image background.

 


Other Menus

Data Menu
Description
Object Histogram

Opens a Histogram window to show the selected object histogram.
 

Object Statistics

Calculates the statistics value for only the selected object.

Lane Profile Opens the Lane Profile window. This window shows in horizontal way a column or row from an array of objects.
Adjust pixel values

Allows inverting pixel values and modifying the pixels range. See Adjust pixel values window.

Channels menu

Sets which image channel will be used to perform the calculations.

Use other channels than Grayscale only if the image is a color one.

See also Color Channels

The conversion factor doesn't influence how Pixel Profile or Array Analyzer work. It only affects values written into the Measurements Pane.