Find Objects Automatically (Find & Count Objects)

Main Menu: View > Find Objects
Shortcut:
F10
Toolbar button:

How objects are searched for

Bersoft Image Measurements (BIM) uses an automatic method to separate objects from the background in an image.

The background should always be brighter than the objects. If the background is darker than the objects the image should be inverted, by selecting the Invert checkbox in the Preprocessing tab.

In some cases it may be necessary to adjust the gamma/contrast/brightness of the image before processing them for locating objects, continue reading this page to know about that issue.

If at least one image is opened inside BIM, it will be automatically processed when you open de Find Objects window. If you want to process several images use the File->Add Images menu to load them.

 

On the left of the Find Objects  window there are several gray tabs. Each tab can be expanded or collapsed by clicking on its title.

Threshold Tab

Threshold

Defines the point that separates background from objects. Objects will grow or shrink or appear an disappear when modifying this value.

Filter Tab

Filter by size

Defines the minimum size that an object needs to be to be detected.*

Max. Value

Sets the maximum value that the filter slider has.

Axis Ratio (circularity)

The software will calculate the ellipse that encloses each object and will filter out objects that are below the specified ellipse axis ratio (1 = 1:1 ratio).

Exclude Objects at Edges

Those objects that touch the edges of the image will be excluded.

Preprocessing Tab

Blur

Smooths objects.*

Shrink

Shrinking objects is useful to separate objects joined by spikes.*

Grow

Objects can be shrink and grow to get smoother object boundaries.*

Color

Found objects will be painted this color. Since the color is shown over the original image, the Opacity setting will affect the intensity of the color.
Objects that are filtered out are always drawn in black.

Invert

Inverts (negative image) the image before processing it for finding objects. The background should always be brighter than the objects. If the background is darker than objects to be found the image should be inverted.

Options Tab

Color

Sets the color to draw the found objects.

Auto Apply

If this option is selected, BIM automatically starts finding objects in the current image  when any setting is changed, otherwise it will only search for objects only when the Apply button is clicked.

Apply

Click here to start searching for objects in the current image.

Controls to set the zoom and opacity of the image (below the image)

Zoom slider

Changes the magnification level of an image.

Fit

Adjust the image size to fit into the window.

Opacity slider

Since the objects are shown above the original image, the opacity slider modifies the intensity of the colors of the objects and makes more or less faint the original image in the background.

Adjust Brightness / Contrast / Gamma values Tab (above the image)

The Reset button sets back Brightness, Contrast and Gamma value to its original values, so the image is displayed without modifications.
When processing a single image, click Apply before processing the image with the new adjustments.
When processing a series of images, all the images will be adjusted following the settings in this tab before processing them. The original files will not be modified in any way.

* It this setting value is set to 0, it will be disabled.

Processing several images at once

If only an image has been opened, the file list box on the right side will not be shown. Only when loading more than one image, the file list will be shown and the Process All button will be visible on top of it.

When Process All is clicked all images in the list will be processed using the current settings.

Usually it is convenient to test one single image with different settings, until achieving the best results, before processing a whole bunch of images. If you plan to process similar images in the future, you may want to save the current processing settings, to be able to reuse them when processing another images. To save or load the processing settings use the File->Load/Save Settings menu items.

After all images are processed the Image Series Data for all objects will be shown in the data grid. Alternatively, a summary can be viewed by selecting the View->Images Series Summary menu.

To view the data pertaining to a single image (after processing a whole series) click the image file name on the file list on the right side, to see its measurements in the data grid.

Menus

Menu/Toolbar
Commands

Shortcut
keys

Description
File Menu

 

 

 

Add Images...

 

One or several images can be selected and added to the file list. If only one image is added. It will be processed automatically. If several images are added, they will be processed when you click the Process All button.

Load Settings...

 

 

Loads previous saved settings.

Save Settings...

 

 

Saves the settings used for finding objects as a file with .fsof file extension.

Export as

 

The Export command that can be used to save the data grid values as CSV, ASCII or HTML files.

CVS file
Saves the data as a Comma delimited text file with .CSV file extension. Spreadsheets programs, including Excel and statistical programs can read this format.

HTML file
Saves the data as an HTML file with .htm file extension.

ASCII file
Saves the data as a text only file.

Print

 

Prints the datasheet values. See Print  Options

Edit Menu

 

 

 

Copy

Ctrl-C

Copies the selected data grid cells to the Windows Clipboard.
Copy to Excel

 

Starts Excel, creates a Worksheet and copies and pastes the selected data grid cells there.
Select All

 

Ctrl-A

Selects all cells in the data grid.
View Menu

 

 

 

Images Series Summary

 

 

This command only is enabled after processing a series of images.

Images Series Data

 

 

This command only is enabled after processing a series of images.

Show Bounding Box Information

 

 

The Bounding Box is an hypothetical box that fully encloses each found object. If this menu item is selected, the X and Y coordinates for each bounding box will be shown as well as its width and height.
Sort Menu

 

 

 

By Diameter

 

 

Sorts the data grid by droplet diameter. This menu only is visible when measuring spray droplets.
The droplets diameter is calculated by using this formula: Dd = 1.06 As 0.455.

By Area

 

 

Sorts the data grid by object or droplet area.

By Perimeter

 

 

Sorts the data grid by object or droplet perimeter.

 Menu

 

 

Opens this Help page.

 

See also:

Select Find Objects Method

Find Objects by Color