Measurements Pane

Main Menu: View > Measurements Pane
Keyboard:
Ctrl-G
Toolbar button:

The Measurements Pane is where all measurements done with the Measurement Tools are recorded.

Measurements are always recorded internally in pixels, but its values are displayed adjusted by the current conversion factor and if a formula is set the measurement values will be modified by it as well. The conversion factor is always shown on the Measurement Pane right most menu.

Each time the image is saved, also the measurements will be are saved along as a measurements file, with the same name than the image, but with .msr file extension.

By way of example, if an image is named wood_m.png, the measurements file will be automatically saved as wood_m.png.msr. If you rename the image outside Bersoft Image Measurement, take care of renaming the measurement file accordingly, otherwise it will not be loaded with the image. If you save the image with another filename using Bersoft Image Measurement, the measurements will be saved along with the proper file name.

If the image was not modified, only the measurements will be saved each time the Save button is clicked. In that way a JPEG file will not lose quality when saving measurements many times.

Each time the image is re-opened also the related measurement file will be loaded, provided than it is kept in the same directory where the image is located.

Each image has its own Measurement window, to join measurements from different images in a single place, they should be sent to the Results Window, see the description for Send Data to Results Window command below to learn more.

The recorded measurements are shown in a datasheet, each measurement in a row.

The Sel and View  checkbox cells that appears on the left of each row allow selecting and showing or hiding the measurement shown in that row. Hidden measurements still appear in the measurement window, but they are not drawn on the image.

Alternatively, the View menu allows hiding some kind of measurements in the Measurements Pane. This is useful if you don't want to send all measurements to the Results window, nor use all them to draw a chart of get statistics.

The Length/Per column shows either the segment length of the measurement perimeter. In the case of angles, it shows the sum of the length of the three angle sides.

The Options column has a drop-down list box that is used to change some options for the measurement on that row, depending of the kind of measurement (line, area, angle, etc.), different options may appear:

The Inv. column shows if the angle has been inverted. All the other cells simply show the measurement features. Depending on the tool used to perform each measurement some cells may be blank.

The measurements can be edited at any time, also its color and font settings can be modified or they can be deleted from the image if needed.

When a measurement is modified, the values shown by the datasheet will reflect the change automatically. See also: How to modify measurements.

Measurements are numbered sequentially, therefore when one measurement is deleted the measurements numbering continuity is broken.
In case you want to keep the numbering continuity use the menu command  Measurements > Clear counting gaps; it will renumber all measurements and also correct any duplicated numbering. Learn more.

Menu
Commands

Description
File Menu

 

Send Visible Data to
Results Window

The Results Window is meant to consolidate data from more than one image in a single database. When data is sent to the Results Window you will be asked to assign a series number to the data, in that way different measurements can be sorted out in different Series in the Results Window.

Only measurements with the View cell checked  visible will be processed.

Import Measurements

 

Measurements from another image can be imported, adding them to the current image. Notice that the conversion factor for those measurements will be imported as well and will replace the current image conversion factor. Measurements exported as MSR files can be imported as well.

Export Measurements

The Export command that can be used to save the measurements as CSV, MSR, PDF or HTML files. Learn more.

Global Metadata Settings: Opens the Global Metadata Tab in the Preferences window.

Embed global metadata when exporting measurements: Only if this option is selected the metadata will be embedded.

Print

Prints the Measurements datasheet. See Print  Options

Edit Menu

 

 

Copy

Copies the selected cells to the Windows Clipboard.
Delete Selected Measurements

 

Deletes all selected measurements.

Set Font/Color for Selected Measurement

Opens the Set Measurement Color window, which allows to modify the lines, background and font  color and the typeface for the selected measurements.

Select All

 

Selects all Measurements.

Unselect All

 

Unselects all Measurements.

Select All Modified Measurements

 

Selects all Measurements that were modified after its creation.
Changing a measurement Color or Font doesn't mark the measurement as modified, only changing its position or measure will do that.

Analyze

 

 

Compare selected measurements

 

Compares two measurements and finds the differences between them. Only two measurements should be selected before using this command.

Depending of the kind of measurements selected you will able to compare measurements of area, perimeter, length or measure the distance between the centroids.

Get Statistics from visible measurements

Opens a statistics window with the statistics for all visible measurements in the Measurements Pane.
Only visible measurements will be used. To get further statistics, send the data to the Results Windows and get the statistics from there.

View

 

 

Charts

Displays different kinds of charts. Before displaying the chart you should select which feature (length, area, angle, # points, centroid X, centroid Y, width or height).
Only visible measurements will be used.
Also is required to select if you want to graph the feature from all tools or just from some specific tool  (in case you have measurements takes with different tools).
Learn more
.

Show Labels
Show Centroid
Show Full Date
Show Creation Date
Show Last Modification Date
Show Title

 

The selected features will appear in the datasheet.
By selecting only the some features, the datasheet will have less columns, providing so more room for the other columns.

Counter
Automatic Area
Segment
Polygon (Per./Area)
Angle
Rectangular Area
Elliptical Area

 

By selecting/deselecting these menu items you can show or hide all measurements from different tools.

This is useful if you don't want to send all measurements to the Results window, nor use all them to draw a chart of get statistics.

Refresh

 

Refreshes the Measurements grid.

Align

 

 

Left

 

 

Top

 

 

Bottom

 

 

Conversion Factor:

 

Besides acting as a menu, here you can see the actual Conversion Factor.

Set Conversion Factor

 

Opens the Conversion Factor window.

Set Measurement Unit

 

Opens a Dialog Box to specify the measurement unit name that will be drawn on the screen. If no measurement unit is specified, the measurements on the image will be displayed as only numbers, otherwise the chosen measurement unit will be displayed after the numbers.
All measurements on the same image share the same measurement unit and the same conversion factor.