Video Capture

Main Menu: File > Acquire > Start Video Capture
Toolbar button:  

Note: To capture Video Microsoft Direct X 8 (or later) and Direct Show compatible equipment  is required

The video feed can be seen on the video capture window or on an image window, in order to perform measurements on the live video feed and/or add frames to the database.

Step 1

Start video capturing  by clicking the Video Capture button :

 

Step 2

Select the Video Source and Mode to see the live video feed in the Video Capture window. The Dialogs list menu, in the Settings tab, allows adjusting the video brightness and other Video Source settings, like the Video Crossbar that is used to select which video input is going to be used (when more than a single input pin is available).

That is the only configuration you need to perform, if a video source is attached to your computer  you will see the video in the Capture window.

From there you can save frames as still images or record the video as a movie.

Click the button to switch the video feed to an image window when you can perform measurements, if that is required.

 

Step 3

Notice the Stop and Pause buttons at the top left in the image below. At any moment you can stop the live video feed to measure objects or save frames as still images.

 

Step 4

Also, it is easy adding captured image frames to the active database.

Video Capture window commands

Besides the Settings tab, there are two tabs more, Grid & Guides and Adjustments

Button

Menu

Function

 

Settings > Load Grid, Guides & Image Mask Settings

Settings > Save Grid, Guides & Image Mask Settings

These menu command Load or Save the Grid spacing and color, the Guides placement and color and the Image Mask selection and placement.

Capture Frames >
To Screen

Captures the current Video Frame to screen, opening a new image window in Bersoft Image Measurement.

Take care of not opening too many windows to avoid running out of RAM and so hanging the software.

Capture to Video File

Opens the Video Capture configuration screen, where capturing options as well as video format, compression and location are selected, previous to start the capture.

After capturing to a Video File, still images can be extracted from the video file, in order to measure them, by opening the file with Bersoft Image Measurement and extracting from it the desired frames.

Capture Frames >
Directly to File

Opens a Save Image As Dialog to select where to save the captured frame.

Capture Frames >
Automatic Capture

Opens the Automatic Capture Settings windows where you can set how many frames, and with which interval you want to capture automatically, as well as where to save the still image files and under which names and image format.

When capturing to still images some frames may be dropped (lost) if the capture interval is very small (like 1 or 2 frames). Use Capture to Video File to avoid losing frames

Live Capture

Shows the video feed on a new image window, where it can be measured, paused and worked on as any other image.

 

Effects

This menu has rotation and flip effects. Effects will be applied to the captured still images as well to the screen, but when capturing video, it will be saved without any effects.

 

Zoom

The Zoom setting reduces or enlarges the image. The captured  video and still images, will always appear at 100% zoom.

The Stretch Filter submenu includes five different stretch filters:

  1.     Nearest

  2.     Linear

  3.     Spline

  4.     Lanczos

  5.     Mitchell

The default filter is Nearest. When Zoom is 100% no stretch filter will be applied.

When selecting different stretch filters the image quality will change, either subtly or markedly.

The selected stretch filter only will affect the image as seen on the screen, the captured images will not be affected by it.

The stretch filter choice depends on the computer power, frame grabber and video characteristics.

 

View >
Refresh Screen

Use this command in case the video is not showing, to refresh the screen and force the video to appear.

 

View > Grid

View > Guides

The menu commands show or hide the Grid and the Guides by selecting or deselecting the corresponding menu check boxes.

To configure the Grid and the Guides click on the Grid & Guides tab. From there the grid spacing can be set at any size. You can also change its color at any time.

The Guides color also can be set in the Settings tab. To add Guides select either the Add/Remove Vertical Guide or Add/Remove Vertical Guide check boxes and then click on the video image where you want to place the Guide.

To remove a Guide, click on the guide or select the Guide coordinate in the Vertical or Horizontal lists on the right of the Settings Tab and then click the Clear button besides the list.

Selected Guides can also be adjusted pixel y pixel by using the arrow buttons.

Several guides can be selected at once in the guides list.

See also the Settings menu description above.

 

View > Load Image Mask

View >View Image Mask

View >Clear Image Mask

View >Move Image Mask

Image Masks are images saved as Windows Bitmap (.BMP) files and are used to superpose drawings (lines, angles, circles or any image) to the live video images.

The Load Image Mask menu loads and shows an image on the video image. All white pixels in the Image Mask image will become transparent when it is superposed on the live video.

The Image Mask location (which is centered by default) can be adjusted by using the View >Move Image Mask menu.

See also the Settings menu description above.

Some video cameras may distort images, please see Lens Calibration to know how to correct lens distortions.